Only $2.99/month
Key Concepts:

Terms in this set (357)

Enter OSPF router configuration mode:

R1(config)# router ospf 10 ! 10 = process ID

Configure one or more network commands to identify which interfaces will run OSPF:

R1(config-router)# network 10.0.0.0 0.255.255.255 area 0
R1(config-router)# network 172.16.8.0 0.0.7.255 area 0
R1(config-router)# network 192.168.1.254 0.0.0.0 area 1

Configure router ID either (Optional):

Using router-id ospf subcommand:

R1(config-router)# router-id 1.1.1.1

Configuring an IP address on a loopback interface:

R1(config)# interface loopback 0
R1(config-if)# ip address 1.1.1.1 255.255.255.255

Change Hello and Dead intervals per interface (Optional):

R1(config-if)# ip ospf hello-interval 2
R1(config-if)# ip ospf dead-interval 6

Impact routing choices by tuning interface cost using one of the following ways (Optional):

Changing interface cost:

R1(config-if)# ip ospf cost 55

Changing interface bandwidth:

R1(config-if)# bandwidth 128 ! in Kbps

Changing the reference bandwidth that used by OSPF to calculate the cost:

R1(config-router)# auto-cost reference-bandwidth 1000 ! in Mbps

Disabling OSPF on a certain interface (Optional):

R1(config-router)# passive-interface serial 0/0

Configuring OSPF authentication (Optional):

Type 0 authentication (none):

R1(config-if)# ip ospf authentication null

Type 1 authentication (clear text):

R1(config-if)# ip ospf authentication
R1(config-if)# ip ospf authentication-key cisco

Type 2 authentication (md5):

R1(config-if)# ip ospf authentication message-digest
R1(config-if)# ip ospf message-digest-key 1 md5 cisco

Configure maximum equal-cost paths (Optional):

R1(config-router)# maximum paths 6
Multipoint (one subnet)

Give the interface an ip address and enable Frame Relay encapsulation:

R1(config)# interface serial 0/0
R1(config-if)# ip address 1.1.1.1 255.255.255.0
R1(config-if)# encapsulation frame-relay (ietf)

Configure LMI signaling type: (Optional as discussed with ISP):

R1(config-if)# frame-relay lmi-type ansi ! options: ansi, cisco, q933a

Configure Frame Relay mapping:

R1(config-if)# frame-relay map ip 1.1.1.2 102 broadcast (ietf)
R1(config-if)# frame-relay map ip 1.1.1.3 103 broadcast
R2(config)# interface serial 0/0
R2(config-if)# ip address 1.1.1.2 255.255.255.0
R2(config-if)# encapsulation frame-relay
R2(config-if)# frame-relay map ip 1.1.1.1 201 broadcast
R2(config-if)# frame-relay map ip 1.1.1.3 201 broadcast
R3(config)# interface serial 0/0
R3(config-if)# ip address 1.1.1.3 255.255.255.0
R3(config-if)# encapsulation frame-relay
R3(config-if)# frame-relay map ip 1.1.1.1 301 broadcast
R3(config-if)# frame-relay map ip 1.1.1.2 301 broadcast
Point-to-point (different subnets; one subnet per subinterface)

Enable Frame Relay encapsulation:

R1(config)# interface serial 0/0
R1(config-if)# encapsulation frame-relay

Give an ip address to a subinterface and configure its DLCI:

R1(config)# interface serial 0/0.102 point-to-point
R1(config-subif)# ip address 1.1.1.1 255.255.255.0
R1(config-subif)# frame-relay interface-dlci 102
R1(config)# interface serial 0/0.103 point-to-point
R1(config-subif)# ip address 2.2.2.1 255.255.255.0
R1(config-subif)# frame-relay interface-dlci 103
R2(config)# interface serial 0/0
R2(config-if)# encapsulation frame-relay
R2(config)# interface serial 0/0.201 point-to-point
R2(config-subif)# ip address 1.1.1.2 255.255.255.0
R2(config-subif)# frame-relay interface-dlci 201
R3(config)# interface serial 0/0
R3(config-if)# encapsulation frame-relay
R3(config)# interface serial 0/0.301 point-to-point
R3(config-subif)# ip address 2.2.2.2 255.255.255.0
R3(config-subif)# frame-relay interface-dlci 301
1. HSRP authentication is carried out in clear text.
2. The hosts served by HSRP router use the IP address of virtual router as the default IP address.
3. When an Active router fails in HSRP environment, Standby router assumes the Active router role.
This new Active router will remain as Active router even if the failed Active router comeback to service,
irrespective of the priority levels.
4. The default HSRP standby priority is 100. If the standby priorities of routers participating in HSRP are
same, the router with the highest IP address becomes the Active router.
5. Within the standby group of routers, the router with the highest standby priority in the group becomes
the active router. For example, a router with a priority of 100 will become active router over a router with
a priority of 50. The active router forwards packets sent to the virtual router. It maintains its active state
by using Hello messages.
6. Each router in a standby group can be assigned a priority value. The range of priority values is between
0 and 255 (including 0 and 255). The default priority assigned to a router in a standby group is 100. The
router with numerically higher priority value will become Active router in the HSRP standby group.
7. All routers in an HSRP standby group can send and/or receive HSRP message. Also, HSRP
protocol packets are addressed to all-router address (224.0.0.2) with a TTL of 1.
Note that the HSRP messages are encapsulated in the data portion of UDP packets.
8. In HSRP, the MAC address used by virtual router is made up of the following three components:
a. Vendor ID: The first three bytes of the MAC address correspond to the vendor ID.
b. HSRP ID: The next two bytes of the MAC address correspond to HSRP code. It is always 07.ac.
Therefore, the virtual router MAC address will have 07.ac in the fourth and fifth bytes.
c. Group ID: The last byte of the MAC address is the group's identification number.